The headline "Mozilla Riddled with Fixed Security Holes" on MozillaZine made me laugh.

One of the six bugs (147754), and coincidently, the one I reported, was fixed way back in 1.0. What, are they having such trouble finding security issues that they have to use older versions of products instead?